谷歌要求 Android 应用都要在 2019 年 8 月前支持 64-bit
首页 > 观测 > 数码科技    作者:剧毒术士马文   2017年12月20日 22:34 星期三   热度:165°   0条评论    
时间:2017-12-20 22:34   热度:165° 

Android 系统自 2015 年推出 Lollipop 开始就开始支持运作 64-bit 应用,但随着 64-bit 处理器的成熟和广泛应用,谷歌也要把它变成预设要求了。在 2019 年 8 月前,所有在 Play 上架的 app 都要支持 64-bit,但不会强制要求取消对 32-bit 硬件的支持。谷歌表示他们最终的目标是 Android 设备只会支持 64-bit 应用,所以开发者们都不要偷懒啰。


img046.jpg


除了对 64-bit 的支持外,谷歌还要求在 2018 年的 8 月前,新的 app 都要对应 Android Oreo 的 API。这不是要求 app 的最低系统要求要提高至 Oreo,但也需要支持这新系统的一些功能;现已上架的 app 则需要在 11 月之前跟进有关要求。另外在 2018 年年初,谷歌自己也会开始加入一些安全元数据到 APK,用作认证 app 的来源真实性,确保是真正从 Play 商店下载而来的。

对比苹果早在 2015 年 2 月就要求 iOS 应用支持 64-bit,并在 iOS 11 正式取消 32-bit 的支持,谷歌看似是晚了一点。可是当考虑到 Android 设备的碎片化问题,就会明白到要在系统上进行改革的难度是更高的。

经由: Engadget
来源: Android Developers Blog
二维码加载中...
本文作者:剧毒术士马文      文章标题: 谷歌要求 Android 应用都要在 2019 年 8 月前支持 64-bit
本文地址:http://mykancolle.com/?post=3930
声明:若无注明,本文皆为“MoePC”原创,转载请保留文章出处。

WRITTEN BY

avatar

返回顶部    首页     管理   注册   
版权声明       pw:mykancolle.com或moepc.net (有时需加www.) 若被菊爆请留言补档
内容来源于网络,并不代表本站赞同其观点和对其真实性负责。
如涉及作品内容、版权和其它问题,请在30日内与本站联系,我们将在第一时间删除内容。
本站资源仅为个人学习测试使用,请在下载后24小时内删除,不得用于商业用途,否则后果自负,请支持正版!
illust:Atha/an2a Foreign visitors, GoogleTranslate will help   sitemap